summaryrefslogtreecommitdiffstats
path: root/bit
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>2002-07-30 18:09:11 +0000
committerEric Norum <WENorum@lbl.gov>2002-07-30 18:09:11 +0000
commitb2e1757903be8a77c03f3fea68179790fc8ee24a (patch)
tree0173ffbc5e97b02b4b3b3b71139bfd7390db36ff /bit
parentThis commit was generated by cvs2svn to compensate for changes in r768, (diff)
downloadrtems-addon-packages-b2e1757903be8a77c03f3fea68179790fc8ee24a.tar.bz2
Add new readline package
Diffstat (limited to 'bit')
-rwxr-xr-xbit13
1 files changed, 10 insertions, 3 deletions
diff --git a/bit b/bit
index a1aef70..cba0c2c 100755
--- a/bit
+++ b/bit
@@ -2,12 +2,19 @@
set -ex
-PACKAGES="avl-1.4.0 ncurses-5.2 readline-4.2"
+PACKAGES="avl-1.4.0 ncurses-5.2 readline-4.3"
for p in $PACKAGES
do
- pname=`echo $p | sed -e '/-.*/s///'`
- (cd $p ; make -f ../RTEMS_Makefiles/Makefile.$pname)
+ (
+ cd $p
+ makefile="../RTEMS_Makefiles/Makefile.$p"
+ if [ \! -r "$makefile" ]
+ then
+ makefile="`echo $makefile | sed -e '/-.*/s///'`"
+ fi
+ make -f "$makefile"
+ )
done
for p in $PACKAGES