summaryrefslogtreecommitdiff
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-12-07 23:44:43 +0530
committerJoel Sherrill <joel@rtems.org>2018-12-07 18:39:01 -0600
commitaad6551b5efd639fbdbc85274555427c68960739 (patch)
treedd6982c3016e17efb0c24d91b809c2abc81732ee /testsuites/psxtests/Makefile.am
parentadd0b6a3f5cd7638285aeb5f6132aee20af9ca70 (diff)
psxhdrs: POSIX API Signature Compliance Tests for netdb.h (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 736e8c4299..62378f1182 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1579,7 +1579,30 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/inttypes/strtoimax.c \
psxhdrs/inttypes/strtoumax.c \
psxhdrs/inttypes/wcstoimax.c \
- psxhdrs/inttypes/wcstoumax.c
+ psxhdrs/inttypes/wcstoumax.c \
+ psxhdrs/netdb/endhostent.c \
+ psxhdrs/netdb/endnetent.c \
+ psxhdrs/netdb/endprotoent.c \
+ psxhdrs/netdb/endservent.c \
+ psxhdrs/netdb/sethostent.c \
+ psxhdrs/netdb/setnetent.c \
+ psxhdrs/netdb/setservent.c \
+ psxhdrs/netdb/gethostent.c \
+ psxhdrs/netdb/getprotoent.c \
+ psxhdrs/netdb/getnetent.c \
+ psxhdrs/netdb/getservent.c \
+ psxhdrs/netdb/freeaddrinfo.c \
+ psxhdrs/netdb/gai_strerror.c \
+ psxhdrs/netdb/getaddrinfo.c \
+ psxhdrs/netdb/gethostbyaddr.c \
+ psxhdrs/netdb/gethostbyname.c \
+ psxhdrs/netdb/getnameinfo.c \
+ psxhdrs/netdb/getnetbyname.c \
+ psxhdrs/netdb/getprotobyname.c \
+ psxhdrs/netdb/getprotobynumber.c \
+ psxhdrs/netdb/getservbyname.c \
+ psxhdrs/netdb/getservbyport.c \
+ psxhdrs/netdb/h_errno.c
## Not supported by RTEMS, but POSIX API Compliance tests exist.