summaryrefslogtreecommitdiff
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorMarçal Comajoan Cara <mcomajoancara@gmail.com>2018-12-07 18:59:38 +0100
committerJoel Sherrill <joel@rtems.org>2018-12-07 18:34:31 -0600
commitadd0b6a3f5cd7638285aeb5f6132aee20af9ca70 (patch)
tree16ef23f33c5391315b14060d41886526dc7cac55 /testsuites/psxtests/Makefile.am
parentf70079ca20b11da6e481ddfeab4516545ec71cbd (diff)
Implement POSIX API Signature Compliance Tests for uchar.h
This header file is C11 and not currently supported by RTEMS. See #3643. This work was part of GCI 2018.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 1ac5a31df4..736e8c4299 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1612,6 +1612,10 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
## lib_a_SOURCES += psxhdrs/ucontext/makecontext.c See ticket #3640
## lib_a_SOURCES += psxhdrs/ucontext/setcontext.c See ticket #3640
## lib_a_SOURCES += psxhdrs/ucontext/swapcontext.c See ticket #3640
+## lib_a_SOURCES += psxhdrs/c11/uchar/c16rtomb.c See ticket #3643
+## lib_a_SOURCES += psxhdrs/c11/uchar/c32rtomb.c See ticket #3643
+## lib_a_SOURCES += psxhdrs/c11/uchar/c32rtomb.c See ticket #3643
+## lib_a_SOURCES += psxhdrs/c11/uchar/mbrtoc32.c See ticket #3643
endif
rtems_tests_PROGRAMS = $(psx_tests)