summaryrefslogtreecommitdiff
path: root/rtems-test-template/sptest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rtems-test-template/sptest/Makefile.am')
-rw-r--r--rtems-test-template/sptest/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/rtems-test-template/sptest/Makefile.am b/rtems-test-template/sptest/Makefile.am
new file mode 100644
index 0000000..0f35215
--- /dev/null
+++ b/rtems-test-template/sptest/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = @LOWER@
+@LOWER@_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = @LOWER@.scn
+dist_rtems_tests_DATA += @LOWER@.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(@LOWER@_OBJECTS) $(@LOWER@_LDADD)
+LINK_LIBS = $(@LOWER@_LDLIBS)
+
+@LOWER@$(EXEEXT): $(@LOWER@_OBJECTS) $(@LOWER@_DEPENDENCIES)
+ @rm -f @LOWER@$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am