summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 26691071a1..1607ac6adf 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -338,6 +338,17 @@ psxtmnanosleep02_CPPFLAGS = $(AM_CPPFLAGS) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmonce01
+psxtm_tests += psxtmonce01
+psxtm_docs += psxtmonce01/psxtmonce01.doc
+psxtmonce01_SOURCES = psxtmonce01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmonce01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmonce01) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
if TEST_psxtmrwlock01
psxtm_tests += psxtmrwlock01
psxtm_docs += psxtmrwlock01/psxtmrwlock01.doc