summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-06 23:59:10 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-06 18:36:08 -0600
commit9bb395167a1cc7d8551d217825313bffcd0d8e1b (patch)
tree0342b45b7d975f83cae8493d7ae1d565af7ec2f6 /testsuites/psxtmtests/Makefile.am
parentscore: Optimize Objects_Information (diff)
downloadrtems-9bb395167a1cc7d8551d217825313bffcd0d8e1b.tar.bz2
psxtmonce01: New test written by Himanshu40 as part of GCI2018
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 26691071a1..1607ac6adf 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -338,6 +338,17 @@ psxtmnanosleep02_CPPFLAGS = $(AM_CPPFLAGS) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmonce01
+psxtm_tests += psxtmonce01
+psxtm_docs += psxtmonce01/psxtmonce01.doc
+psxtmonce01_SOURCES = psxtmonce01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmonce01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmonce01) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
if TEST_psxtmrwlock01
psxtm_tests += psxtmrwlock01
psxtm_docs += psxtmrwlock01/psxtmrwlock01.doc