summaryrefslogtreecommitdiffstats
path: root/ports/beagleboneblack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/beagleboneblack/Makefile')
-rw-r--r--ports/beagleboneblack/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/ports/beagleboneblack/Makefile b/ports/beagleboneblack/Makefile
index 0525dec..db285bd 100644
--- a/ports/beagleboneblack/Makefile
+++ b/ports/beagleboneblack/Makefile
@@ -83,8 +83,15 @@ OBJS = $(LOCSOBJ) $(CPUSOBJ) $(LOCCOBJ) $(CPUCOBJ) $(COMCOBJ) \
# load a new version onto an already running system.
#
boot: $(BUILDDIR)/boot.$(FILETYPE)
+ $(CC) $(ASMFLAGS) -D \
+ BIN_SIZE=$(shell wc --bytes build_$(PLATFORM)/boot.bin | cut -f 1 -d ' ') \
+ -o gp_header.o gp_header.S
+ $(OBJCOPY) -O binary gp_header.o build_$(PLATFORM)/gp_header.bin
+ @cat build_$(PLATFORM)/gp_header.bin build_$(PLATFORM)/boot.bin > build_$(PLATFORM)/MLO
@echo Boot version of uMon built under $(BUILDDIR) ...
@ls $(BUILDDIR)/boot*
+ @echo Boot version of uMon attached with GP header build under $(BUILDDIR) ...
+ @ls $(BUILDDIR)/MLO
# ramtst:
# A shortcut to $(BUILDDIR)/ramtst.$(FILETYPE). This is a version of uMon