summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm26/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/tmtests/tm26/Makefile.am')
-rw-r--r--testsuites/tmtests/tm26/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/tmtests/tm26/Makefile.am b/testsuites/tmtests/tm26/Makefile.am
index 75870b5179..9c6e6d9d7d 100644
--- a/testsuites/tmtests/tm26/Makefile.am
+++ b/testsuites/tmtests/tm26/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore semaphore
-rtems_tests_PROGRAMS = tm26.exe
-tm26_exe_SOURCES = task1.c system.h fptest.h ../include/timesys.h \
+rtems_tests_PROGRAMS = tm26
+tm26_SOURCES = task1.c system.h fptest.h ../include/timesys.h \
../../support/src/tmtests_empty_function.c
dist_rtems_tests_DATA = tm26.doc
@@ -14,17 +14,17 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-tm26_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+tm26_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(tm26_exe_OBJECTS) $(tm26_exe_LDADD)
-LINK_LIBS = $(tm26_exe_LDLIBS)
+LINK_OBJS = $(tm26_OBJECTS) $(tm26_LDADD)
+LINK_LIBS = $(tm26_LDLIBS)
-tm26.exe$(EXEEXT): $(tm26_exe_OBJECTS) $(tm26_exe_DEPENDENCIES)
- @rm -f tm26.exe$(EXEEXT)
+tm26$(EXEEXT): $(tm26_OBJECTS) $(tm26_DEPENDENCIES)
+ @rm -f tm26$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am