summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm20/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/tmtests/tm20/Makefile.am')
-rw-r--r--testsuites/tmtests/tm20/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/tmtests/tm20/Makefile.am b/testsuites/tmtests/tm20/Makefile.am
index f49dbd0194..7427527f12 100644
--- a/testsuites/tmtests/tm20/Makefile.am
+++ b/testsuites/tmtests/tm20/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io partition region semaphore
-rtems_tests_PROGRAMS = tm20.exe
-tm20_exe_SOURCES = task1.c system.h ../include/timesys.h \
+rtems_tests_PROGRAMS = tm20
+tm20_SOURCES = task1.c system.h ../include/timesys.h \
../../support/src/tmtests_empty_function.c
dist_rtems_tests_DATA = tm20.doc
@@ -14,17 +14,17 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-tm20_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+tm20_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(tm20_exe_OBJECTS) $(tm20_exe_LDADD)
-LINK_LIBS = $(tm20_exe_LDLIBS)
+LINK_OBJS = $(tm20_OBJECTS) $(tm20_LDADD)
+LINK_LIBS = $(tm20_LDLIBS)
-tm20.exe$(EXEEXT): $(tm20_exe_OBJECTS) $(tm20_exe_DEPENDENCIES)
- @rm -f tm20.exe$(EXEEXT)
+tm20$(EXEEXT): $(tm20_OBJECTS) $(tm20_DEPENDENCIES)
+ @rm -f tm20$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am