summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm07/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/tmtests/tm07/Makefile.am')
-rw-r--r--testsuites/tmtests/tm07/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/tmtests/tm07/Makefile.am b/testsuites/tmtests/tm07/Makefile.am
index 5e92732660..2897065e19 100644
--- a/testsuites/tmtests/tm07/Makefile.am
+++ b/testsuites/tmtests/tm07/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore
-rtems_tests_PROGRAMS = tm07.exe
-tm07_exe_SOURCES = task1.c system.h ../include/timesys.h \
+rtems_tests_PROGRAMS = tm07
+tm07_SOURCES = task1.c system.h ../include/timesys.h \
../../support/src/tmtests_empty_function.c
dist_rtems_tests_DATA = tm07.doc
@@ -14,17 +14,17 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-tm07_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+tm07_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(tm07_exe_OBJECTS) $(tm07_exe_LDADD)
-LINK_LIBS = $(tm07_exe_LDLIBS)
+LINK_OBJS = $(tm07_OBJECTS) $(tm07_LDADD)
+LINK_LIBS = $(tm07_LDLIBS)
-tm07.exe$(EXEEXT): $(tm07_exe_OBJECTS) $(tm07_exe_DEPENDENCIES)
- @rm -f tm07.exe$(EXEEXT)
+tm07$(EXEEXT): $(tm07_OBJECTS) $(tm07_DEPENDENCIES)
+ @rm -f tm07$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am