summaryrefslogtreecommitdiffstats
path: root/testsuites/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/support/Makefile.am')
-rw-r--r--testsuites/support/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/testsuites/support/Makefile.am b/testsuites/support/Makefile.am
index 2e92bce1d2..bd6900ef24 100644
--- a/testsuites/support/Makefile.am
+++ b/testsuites/support/Makefile.am
@@ -8,12 +8,13 @@ include_HEADERS = include/tmacros.h include/buffer_test_io.h
all-local: $(PREINSTALL_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/$(dirstamp)
$(PROJECT_INCLUDE)/tmacros.h: include/tmacros.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/tmacros.h
@@ -24,5 +25,6 @@ $(PROJECT_INCLUDE)/buffer_test_io.h: include/buffer_test_io.h $(PROJECT_INCLUDE)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/buffer_test_io.h
CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../automake/local.am