summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spsimplesched01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spsimplesched01/Makefile.am')
-rw-r--r--testsuites/sptests/spsimplesched01/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/spsimplesched01/Makefile.am b/testsuites/sptests/spsimplesched01/Makefile.am
new file mode 100644
index 0000000000..dacfee08ef
--- /dev/null
+++ b/testsuites/sptests/spsimplesched01/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = spsimplesched01
+spsimplesched01_SOURCES = init.c
+
+dist_rtems_tests_DATA = spsimplesched01.scn
+dist_rtems_tests_DATA += spsimplesched01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+spsimplesched01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spsimplesched01_OBJECTS) $(spsimplesched01_LDADD)
+LINK_LIBS = $(spsimplesched01_LDLIBS)
+
+spsimplesched01$(EXEEXT): $(spsimplesched01_OBJECTS) $(spsimplesched01_DEPENDENCIES)
+ @rm -f spsimplesched01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am