summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sprmsched02/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sprmsched02/Makefile.am')
-rw-r--r--testsuites/sptests/sprmsched02/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/sptests/sprmsched02/Makefile.am b/testsuites/sptests/sprmsched02/Makefile.am
new file mode 100644
index 0000000000..4b2a0c87c4
--- /dev/null
+++ b/testsuites/sptests/sprmsched02/Makefile.am
@@ -0,0 +1,22 @@
+
+rtems_tests_PROGRAMS = sprmsched02
+sprmsched02_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = sprmsched02.scn
+dist_rtems_tests_DATA += sprmsched02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sprmsched02_OBJECTS)
+LINK_LIBS = $(sprmsched02_LDLIBS)
+
+sprmsched02$(EXEEXT): $(sprmsched02_OBJECTS) $(sprmsched02_DEPENDENCIES)
+ @rm -f sprmsched02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am