summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spmountmgr01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spmountmgr01/Makefile.am')
-rw-r--r--testsuites/sptests/spmountmgr01/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/sptests/spmountmgr01/Makefile.am b/testsuites/sptests/spmountmgr01/Makefile.am
new file mode 100644
index 0000000000..b556d88208
--- /dev/null
+++ b/testsuites/sptests/spmountmgr01/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = spmountmgr01
+spmountmgr01_SOURCES = init.c
+
+dist_rtems_tests_DATA = spmountmgr01.scn
+dist_rtems_tests_DATA += spmountmgr01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spmountmgr01_OBJECTS) $(spmountmgr01_LDADD)
+LINK_LIBS = $(spmountmgr01_LDLIBS)
+
+spmountmgr01$(EXEEXT): $(spmountmgr01_OBJECTS) $(spmountmgr01_DEPENDENCIES)
+ @rm -f spmountmgr01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am