summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spcbssched01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/spcbssched01/Makefile.am')
-rw-r--r--testsuites/sptests/spcbssched01/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/spcbssched01/Makefile.am b/testsuites/sptests/spcbssched01/Makefile.am
new file mode 100644
index 0000000000..bc0b3e6587
--- /dev/null
+++ b/testsuites/sptests/spcbssched01/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = io semaphore clock
+
+rtems_tests_PROGRAMS = spcbssched01
+spcbssched01_SOURCES = init.c task1.c system.h
+
+dist_rtems_tests_DATA = spcbssched01.scn
+dist_rtems_tests_DATA += spcbssched01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+spcbssched01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spcbssched01_OBJECTS) $(spcbssched01_LDADD)
+LINK_LIBS = $(spcbssched01_LDLIBS)
+
+spcbssched01$(EXEEXT): $(spcbssched01_OBJECTS) $(spcbssched01_DEPENDENCIES)
+ @rm -f spcbssched01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am