summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp31/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp31/Makefile.am')
-rw-r--r--testsuites/sptests/sp31/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp31/Makefile.am b/testsuites/sptests/sp31/Makefile.am
index a01e116fcb..b534796bd2 100644
--- a/testsuites/sptests/sp31/Makefile.am
+++ b/testsuites/sptests/sp31/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = all
-rtems_tests_PROGRAMS = sp31.exe
-sp31_exe_SOURCES = delay.c init.c prtime.c task1.c system.h
+rtems_tests_PROGRAMS = sp31
+sp31_SOURCES = delay.c init.c prtime.c task1.c system.h
dist_rtems_tests_DATA = sp31.scn
dist_rtems_tests_DATA += sp31.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp31_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp31_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp31_exe_OBJECTS) $(sp31_exe_LDADD)
-LINK_LIBS = $(sp31_exe_LDLIBS)
+LINK_OBJS = $(sp31_OBJECTS) $(sp31_LDADD)
+LINK_LIBS = $(sp31_LDLIBS)
-sp31.exe$(EXEEXT): $(sp31_exe_OBJECTS) $(sp31_exe_DEPENDENCIES)
- @rm -f sp31.exe$(EXEEXT)
+sp31$(EXEEXT): $(sp31_OBJECTS) $(sp31_DEPENDENCIES)
+ @rm -f sp31$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am