summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp27/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp27/Makefile.am')
-rw-r--r--testsuites/sptests/sp27/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/testsuites/sptests/sp27/Makefile.am b/testsuites/sptests/sp27/Makefile.am
index a8cff9fd0f..9c3851390f 100644
--- a/testsuites/sptests/sp27/Makefile.am
+++ b/testsuites/sptests/sp27/Makefile.am
@@ -4,28 +4,25 @@
MANAGERS = all
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c
+rtems_tests_PROGRAMS = sp27.exe
+sp27_exe_SOURCES = init.c
-testsdir = $(libdir)/tests
-scndir = $(testsdir)
+scndir = $(rtems_testsdir)
dist_scn_DATA = sp27.scn
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = sp27.doc
-OBJS = $(lib_a_OBJECTS)
-
-PGM = ${ARCH}/sp27.exe
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+sp27_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(sp27_exe_OBJECTS) $(sp27_exe_LDADD)
+LINK_LIBS = $(sp27_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+sp27.exe$(EXEEXT): $(sp27_exe_OBJECTS) $(sp27_exe_DEPENDENCIES)
+ @rm -f sp27.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am