summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp25/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp25/Makefile.am')
-rw-r--r--testsuites/sptests/sp25/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp25/Makefile.am b/testsuites/sptests/sp25/Makefile.am
index e68cd3509e..1c5491d104 100644
--- a/testsuites/sptests/sp25/Makefile.am
+++ b/testsuites/sptests/sp25/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore clock region
-rtems_tests_PROGRAMS = sp25.exe
-sp25_exe_SOURCES = init.c task1.c system.h
+rtems_tests_PROGRAMS = sp25
+sp25_SOURCES = init.c task1.c system.h
dist_rtems_tests_DATA = sp25.scn
dist_rtems_tests_DATA += sp25.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp25_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp25_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp25_exe_OBJECTS) $(sp25_exe_LDADD)
-LINK_LIBS = $(sp25_exe_LDLIBS)
+LINK_OBJS = $(sp25_OBJECTS) $(sp25_LDADD)
+LINK_LIBS = $(sp25_LDLIBS)
-sp25.exe$(EXEEXT): $(sp25_exe_OBJECTS) $(sp25_exe_DEPENDENCIES)
- @rm -f sp25.exe$(EXEEXT)
+sp25$(EXEEXT): $(sp25_OBJECTS) $(sp25_DEPENDENCIES)
+ @rm -f sp25$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am