summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp23/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp23/Makefile.am')
-rw-r--r--testsuites/sptests/sp23/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp23/Makefile.am b/testsuites/sptests/sp23/Makefile.am
index 500297a176..b95fd671c0 100644
--- a/testsuites/sptests/sp23/Makefile.am
+++ b/testsuites/sptests/sp23/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io dual_ported_memory semaphore clock
-rtems_tests_PROGRAMS = sp23.exe
-sp23_exe_SOURCES = init.c task1.c system.h
+rtems_tests_PROGRAMS = sp23
+sp23_SOURCES = init.c task1.c system.h
dist_rtems_tests_DATA = sp23.scn
dist_rtems_tests_DATA += sp23.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp23_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp23_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp23_exe_OBJECTS) $(sp23_exe_LDADD)
-LINK_LIBS = $(sp23_exe_LDLIBS)
+LINK_OBJS = $(sp23_OBJECTS) $(sp23_LDADD)
+LINK_LIBS = $(sp23_LDLIBS)
-sp23.exe$(EXEEXT): $(sp23_exe_OBJECTS) $(sp23_exe_DEPENDENCIES)
- @rm -f sp23.exe$(EXEEXT)
+sp23$(EXEEXT): $(sp23_OBJECTS) $(sp23_DEPENDENCIES)
+ @rm -f sp23$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am