summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp22/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp22/Makefile.am')
-rw-r--r--testsuites/sptests/sp22/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp22/Makefile.am b/testsuites/sptests/sp22/Makefile.am
index cc306e925d..bc092b9979 100644
--- a/testsuites/sptests/sp22/Makefile.am
+++ b/testsuites/sptests/sp22/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io timer semaphore clock
-rtems_tests_PROGRAMS = sp22.exe
-sp22_exe_SOURCES = init.c prtime.c delay.c task1.c system.h
+rtems_tests_PROGRAMS = sp22
+sp22_SOURCES = init.c prtime.c delay.c task1.c system.h
dist_rtems_tests_DATA = sp22.scn
dist_rtems_tests_DATA += sp22.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp22_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp22_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp22_exe_OBJECTS) $(sp22_exe_LDADD)
-LINK_LIBS = $(sp22_exe_LDLIBS)
+LINK_OBJS = $(sp22_OBJECTS) $(sp22_LDADD)
+LINK_LIBS = $(sp22_LDLIBS)
-sp22.exe$(EXEEXT): $(sp22_exe_OBJECTS) $(sp22_exe_DEPENDENCIES)
- @rm -f sp22.exe$(EXEEXT)
+sp22$(EXEEXT): $(sp22_OBJECTS) $(sp22_DEPENDENCIES)
+ @rm -f sp22$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am