summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp17/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp17/Makefile.am')
-rw-r--r--testsuites/sptests/sp17/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp17/Makefile.am b/testsuites/sptests/sp17/Makefile.am
index 51427d3430..202381902e 100644
--- a/testsuites/sptests/sp17/Makefile.am
+++ b/testsuites/sptests/sp17/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io signal semaphore clock
-rtems_tests_PROGRAMS = sp17.exe
-sp17_exe_SOURCES = init.c asr.c task1.c task2.c system.h
+rtems_tests_PROGRAMS = sp17
+sp17_SOURCES = init.c asr.c task1.c task2.c system.h
dist_rtems_tests_DATA = sp17.scn
dist_rtems_tests_DATA += sp17.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp17_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp17_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp17_exe_OBJECTS) $(sp17_exe_LDADD)
-LINK_LIBS = $(sp17_exe_LDLIBS)
+LINK_OBJS = $(sp17_OBJECTS) $(sp17_LDADD)
+LINK_LIBS = $(sp17_LDLIBS)
-sp17.exe$(EXEEXT): $(sp17_exe_OBJECTS) $(sp17_exe_DEPENDENCIES)
- @rm -f sp17.exe$(EXEEXT)
+sp17$(EXEEXT): $(sp17_OBJECTS) $(sp17_DEPENDENCIES)
+ @rm -f sp17$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am