summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp15/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp15/Makefile.am')
-rw-r--r--testsuites/sptests/sp15/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp15/Makefile.am b/testsuites/sptests/sp15/Makefile.am
index 4456b6560c..6e8e588f5e 100644
--- a/testsuites/sptests/sp15/Makefile.am
+++ b/testsuites/sptests/sp15/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io partition semaphore clock
-rtems_tests_PROGRAMS = sp15.exe
-sp15_exe_SOURCES = init.c task1.c system.h
+rtems_tests_PROGRAMS = sp15
+sp15_SOURCES = init.c task1.c system.h
dist_rtems_tests_DATA = sp15.scn
dist_rtems_tests_DATA += sp15.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp15_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp15_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp15_exe_OBJECTS) $(sp15_exe_LDADD)
-LINK_LIBS = $(sp15_exe_LDLIBS)
+LINK_OBJS = $(sp15_OBJECTS) $(sp15_LDADD)
+LINK_LIBS = $(sp15_LDLIBS)
-sp15.exe$(EXEEXT): $(sp15_exe_OBJECTS) $(sp15_exe_DEPENDENCIES)
- @rm -f sp15.exe$(EXEEXT)
+sp15$(EXEEXT): $(sp15_OBJECTS) $(sp15_DEPENDENCIES)
+ @rm -f sp15$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am