summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp14/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp14/Makefile.am')
-rw-r--r--testsuites/sptests/sp14/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp14/Makefile.am b/testsuites/sptests/sp14/Makefile.am
index 620555c688..efea9c1e4b 100644
--- a/testsuites/sptests/sp14/Makefile.am
+++ b/testsuites/sptests/sp14/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io signal timer semaphore clock
-rtems_tests_PROGRAMS = sp14.exe
-sp14_exe_SOURCES = init.c asr.c task1.c task2.c system.h
+rtems_tests_PROGRAMS = sp14
+sp14_SOURCES = init.c asr.c task1.c task2.c system.h
dist_rtems_tests_DATA = sp14.scn
dist_rtems_tests_DATA += sp14.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp14_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp14_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp14_exe_OBJECTS) $(sp14_exe_LDADD)
-LINK_LIBS = $(sp14_exe_LDLIBS)
+LINK_OBJS = $(sp14_OBJECTS) $(sp14_LDADD)
+LINK_LIBS = $(sp14_LDLIBS)
-sp14.exe$(EXEEXT): $(sp14_exe_OBJECTS) $(sp14_exe_DEPENDENCIES)
- @rm -f sp14.exe$(EXEEXT)
+sp14$(EXEEXT): $(sp14_OBJECTS) $(sp14_DEPENDENCIES)
+ @rm -f sp14$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am