summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp13/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp13/Makefile.am')
-rw-r--r--testsuites/sptests/sp13/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp13/Makefile.am b/testsuites/sptests/sp13/Makefile.am
index ebbe69e444..475f4e13e9 100644
--- a/testsuites/sptests/sp13/Makefile.am
+++ b/testsuites/sptests/sp13/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io message semaphore clock
-rtems_tests_PROGRAMS = sp13.exe
-sp13_exe_SOURCES = init.c fillbuff.c putbuff.c task1.c task2.c task3.c system.h
+rtems_tests_PROGRAMS = sp13
+sp13_SOURCES = init.c fillbuff.c putbuff.c task1.c task2.c task3.c system.h
dist_rtems_tests_DATA = sp13.scn
dist_rtems_tests_DATA += sp13.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp13_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp13_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp13_exe_OBJECTS) $(sp13_exe_LDADD)
-LINK_LIBS = $(sp13_exe_LDLIBS)
+LINK_OBJS = $(sp13_OBJECTS) $(sp13_LDADD)
+LINK_LIBS = $(sp13_LDLIBS)
-sp13.exe$(EXEEXT): $(sp13_exe_OBJECTS) $(sp13_exe_DEPENDENCIES)
- @rm -f sp13.exe$(EXEEXT)
+sp13$(EXEEXT): $(sp13_OBJECTS) $(sp13_DEPENDENCIES)
+ @rm -f sp13$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am