summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp11/Makefile.am')
-rw-r--r--testsuites/sptests/sp11/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp11/Makefile.am b/testsuites/sptests/sp11/Makefile.am
index f037fee20a..8ee044e658 100644
--- a/testsuites/sptests/sp11/Makefile.am
+++ b/testsuites/sptests/sp11/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io event timer clock semaphore
-rtems_tests_PROGRAMS = sp11.exe
-sp11_exe_SOURCES = init.c task1.c task2.c timer.c system.h
+rtems_tests_PROGRAMS = sp11
+sp11_SOURCES = init.c task1.c task2.c timer.c system.h
dist_rtems_tests_DATA = sp11.scn
dist_rtems_tests_DATA += sp11.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp11_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp11_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp11_exe_OBJECTS) $(sp11_exe_LDADD)
-LINK_LIBS = $(sp11_exe_LDLIBS)
+LINK_OBJS = $(sp11_OBJECTS) $(sp11_LDADD)
+LINK_LIBS = $(sp11_LDLIBS)
-sp11.exe$(EXEEXT): $(sp11_exe_OBJECTS) $(sp11_exe_DEPENDENCIES)
- @rm -f sp11.exe$(EXEEXT)
+sp11$(EXEEXT): $(sp11_OBJECTS) $(sp11_DEPENDENCIES)
+ @rm -f sp11$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am