summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp09/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp09/Makefile.am')
-rw-r--r--testsuites/sptests/sp09/Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/testsuites/sptests/sp09/Makefile.am b/testsuites/sptests/sp09/Makefile.am
index 1ce78b5147..b77a3cdd69 100644
--- a/testsuites/sptests/sp09/Makefile.am
+++ b/testsuites/sptests/sp09/Makefile.am
@@ -7,27 +7,24 @@ TEST = sp09
MANAGERS = io message dual_ported_memory event multi_processor region \
semaphore signal rate_monotonic timer partition
-C_FILES = init.c delay.c isr.c screen01.c screen02.c screen03.c screen04.c \
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = init.c delay.c isr.c screen01.c screen02.c screen03.c screen04.c \
screen05.c screen06.c screen07.c screen08.c screen09.c screen10.c \
screen11.c screen12.c screen13.c screen14.c task1.c task2.c task3.c \
- task4.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-
-H_FILES = system.h
-noinst_HEADERS = $(H_FILES)
+ task4.c system.h
DOCTYPES = scn doc
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS =
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/sptests.am
@@ -36,7 +33,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)