summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp09/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp09/Makefile.am')
-rw-r--r--testsuites/sptests/sp09/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp09/Makefile.am b/testsuites/sptests/sp09/Makefile.am
index c85cabffe7..4f796cb022 100644
--- a/testsuites/sptests/sp09/Makefile.am
+++ b/testsuites/sptests/sp09/Makefile.am
@@ -5,8 +5,8 @@
MANAGERS = io clock message dual_ported_memory event multi_processor region \
semaphore signal rate_monotonic timer partition
-rtems_tests_PROGRAMS = sp09.exe
-sp09_exe_SOURCES = init.c delay.c isr.c screen01.c screen02.c screen03.c screen04.c \
+rtems_tests_PROGRAMS = sp09
+sp09_SOURCES = init.c delay.c isr.c screen01.c screen02.c screen03.c screen04.c \
screen05.c screen06.c screen07.c screen08.c screen09.c screen10.c \
screen11.c screen12.c screen13.c screen14.c task1.c task2.c task3.c \
task4.c system.h
@@ -18,15 +18,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp09_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp09_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp09_exe_OBJECTS) $(sp09_exe_LDADD)
-LINK_LIBS = $(sp09_exe_LDLIBS)
+LINK_OBJS = $(sp09_OBJECTS) $(sp09_LDADD)
+LINK_LIBS = $(sp09_LDLIBS)
-sp09.exe$(EXEEXT): $(sp09_exe_OBJECTS) $(sp09_exe_DEPENDENCIES)
- @rm -f sp09.exe$(EXEEXT)
+sp09$(EXEEXT): $(sp09_OBJECTS) $(sp09_DEPENDENCIES)
+ @rm -f sp09$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am