summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp08/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp08/Makefile.am')
-rw-r--r--testsuites/sptests/sp08/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp08/Makefile.am b/testsuites/sptests/sp08/Makefile.am
index 14040d61cd..e61c96d63a 100644
--- a/testsuites/sptests/sp08/Makefile.am
+++ b/testsuites/sptests/sp08/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore clock
-rtems_tests_PROGRAMS = sp08.exe
-sp08_exe_SOURCES = init.c task1.c system.h
+rtems_tests_PROGRAMS = sp08
+sp08_SOURCES = init.c task1.c system.h
dist_rtems_tests_DATA = sp08.scn
dist_rtems_tests_DATA += sp08.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp08_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp08_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp08_exe_OBJECTS) $(sp08_exe_LDADD)
-LINK_LIBS = $(sp08_exe_LDLIBS)
+LINK_OBJS = $(sp08_OBJECTS) $(sp08_LDADD)
+LINK_LIBS = $(sp08_LDLIBS)
-sp08.exe$(EXEEXT): $(sp08_exe_OBJECTS) $(sp08_exe_DEPENDENCIES)
- @rm -f sp08.exe$(EXEEXT)
+sp08$(EXEEXT): $(sp08_OBJECTS) $(sp08_DEPENDENCIES)
+ @rm -f sp08$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am