summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp07/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp07/Makefile.am')
-rw-r--r--testsuites/sptests/sp07/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp07/Makefile.am b/testsuites/sptests/sp07/Makefile.am
index 4322cfe925..36111dd019 100644
--- a/testsuites/sptests/sp07/Makefile.am
+++ b/testsuites/sptests/sp07/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore clock extension
-rtems_tests_PROGRAMS = sp07.exe
-sp07_exe_SOURCES = init.c buffered_io.c task1.c task2.c task3.c task4.c \
+rtems_tests_PROGRAMS = sp07
+sp07_SOURCES = init.c buffered_io.c task1.c task2.c task3.c task4.c \
taskexit.c tcreate.c tdelete.c trestart.c tstart.c system.h
dist_rtems_tests_DATA = sp07.scn
@@ -15,15 +15,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp07_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp07_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp07_exe_OBJECTS) $(sp07_exe_LDADD)
-LINK_LIBS = $(sp07_exe_LDLIBS)
+LINK_OBJS = $(sp07_OBJECTS) $(sp07_LDADD)
+LINK_LIBS = $(sp07_LDLIBS)
-sp07.exe$(EXEEXT): $(sp07_exe_OBJECTS) $(sp07_exe_DEPENDENCIES)
- @rm -f sp07.exe$(EXEEXT)
+sp07$(EXEEXT): $(sp07_OBJECTS) $(sp07_DEPENDENCIES)
+ @rm -f sp07$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am