summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp03/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp03/Makefile.am')
-rw-r--r--testsuites/sptests/sp03/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/sptests/sp03/Makefile.am b/testsuites/sptests/sp03/Makefile.am
index bedf79ae99..eaf8ad05ca 100644
--- a/testsuites/sptests/sp03/Makefile.am
+++ b/testsuites/sptests/sp03/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore clock
-rtems_tests_PROGRAMS = sp03.exe
-sp03_exe_SOURCES = init.c task1.c task2.c system.h
+rtems_tests_PROGRAMS = sp03
+sp03_SOURCES = init.c task1.c task2.c system.h
dist_rtems_tests_DATA = sp03.scn
dist_rtems_tests_DATA += sp03.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-sp03_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+sp03_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(sp03_exe_OBJECTS) $(sp03_exe_LDADD)
-LINK_LIBS = $(sp03_exe_LDLIBS)
+LINK_OBJS = $(sp03_OBJECTS) $(sp03_LDADD)
+LINK_LIBS = $(sp03_LDLIBS)
-sp03.exe$(EXEEXT): $(sp03_exe_OBJECTS) $(sp03_exe_DEPENDENCIES)
- @rm -f sp03.exe$(EXEEXT)
+sp03$(EXEEXT): $(sp03_OBJECTS) $(sp03_DEPENDENCIES)
+ @rm -f sp03$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am