summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp02/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/sp02/Makefile.am')
-rw-r--r--testsuites/sptests/sp02/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/testsuites/sptests/sp02/Makefile.am b/testsuites/sptests/sp02/Makefile.am
index 76d637120e..0cf09caef0 100644
--- a/testsuites/sptests/sp02/Makefile.am
+++ b/testsuites/sptests/sp02/Makefile.am
@@ -4,30 +4,27 @@
MANAGERS = io
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c task1.c task2.c task3.c preempt.c system.h
+rtems_tests_PROGRAMS = sp02.exe
+sp02_exe_SOURCES = init.c task1.c task2.c task3.c preempt.c system.h
-testsdir = $(libdir)/tests
-scndir = $(testsdir)
+scndir = $(rtems_testsdir)
dist_scn_DATA = sp02.scn
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = sp02.doc
-OBJS = $(lib_a_OBJECTS)
-
-PGM = ${ARCH}/sp02.exe
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+sp02_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(sp02_exe_OBJECTS) $(sp02_exe_LDADD)
+LINK_LIBS = $(sp02_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+sp02.exe$(EXEEXT): $(sp02_exe_OBJECTS) $(sp02_exe_DEPENDENCIES)
+ @rm -f sp02.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am