summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/sptests/configure.ac')
-rw-r--r--testsuites/sptests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/sptests/configure.ac b/testsuites/sptests/configure.ac
index be69f092b2..ea96dbf9da 100644
--- a/testsuites/sptests/configure.ac
+++ b/testsuites/sptests/configure.ac
@@ -33,6 +33,9 @@ AC_CHECK_SIZEOF([time_t])
AC_CHECK_TYPES([struct _Thread_queue_Queue],[],[],[#include <sys/lock.h>])
AM_CONDITIONAL(HAS__THREAD_QUEUE_QUEUE,test x"${ac_cv_type_struct__Thread_queue_Queue}" = x"yes")
+AC_CHECK_HEADERS([threads.h])
+AM_CONDITIONAL([HAS_THREADS_H],[test x"$ac_cv_header_threads_h" = x"yes"])
+
# Added to newlib pthreads for RTEMS SMP (np), may not be present
AC_CHECK_HEADERS([sys/cpuset.h])
AM_CONDITIONAL(HAS_CPUSET,test x"${ac_cv_header_sys_cpuset_h}" = x"yes")
@@ -43,6 +46,7 @@ AM_CONDITIONAL(HAS_SMP,test "$rtems_cv_RTEMS_SMP" = "yes")
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
+spstdthreads01/Makefile
spsyslock01/Makefile
sptasknopreempt01/Makefile
spintrcritical23/Makefile