summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpatomic07/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smpatomic07/Makefile.am')
-rw-r--r--testsuites/smptests/smpatomic07/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/smptests/smpatomic07/Makefile.am b/testsuites/smptests/smpatomic07/Makefile.am
new file mode 100644
index 0000000000..5e3ebd2b07
--- /dev/null
+++ b/testsuites/smptests/smpatomic07/Makefile.am
@@ -0,0 +1,22 @@
+
+rtems_tests_PROGRAMS = smpatomic07
+smpatomic07_SOURCES = init.c tasks.c system.h ../../support/src/locked_print.c
+
+dist_rtems_tests_DATA = smpatomic07.scn
+dist_rtems_tests_DATA += smpatomic07.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpatomic07_OBJECTS)
+LINK_LIBS = $(smpatomic07_LDLIBS)
+
+smpatomic07$(EXEEXT): $(smpatomic07_OBJECTS) $(smpatomic07_DEPENDENCIES)
+ @rm -f smpatomic07$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am