summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smp01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/smptests/smp01/Makefile.am')
-rw-r--r--testsuites/smptests/smp01/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/smptests/smp01/Makefile.am b/testsuites/smptests/smp01/Makefile.am
new file mode 100644
index 0000000000..a112880372
--- /dev/null
+++ b/testsuites/smptests/smp01/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = smp01
+smp01_SOURCES = init.c tasks.c system.h ../../support/src/locked_print.c
+
+dist_rtems_tests_DATA = smp01.scn
+dist_rtems_tests_DATA += smp01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DSMPTEST
+
+LINK_OBJS = $(smp01_OBJECTS) $(smp01_LDADD)
+LINK_LIBS = $(smp01_LDLIBS)
+
+smp01$(EXEEXT): $(smp01_OBJECTS) $(smp01_DEPENDENCIES)
+ @rm -f smp01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am