summaryrefslogtreecommitdiffstats
path: root/testsuites/rhealstone/rhsemshuffle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/rhealstone/rhsemshuffle/Makefile.am')
-rw-r--r--testsuites/rhealstone/rhsemshuffle/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/testsuites/rhealstone/rhsemshuffle/Makefile.am b/testsuites/rhealstone/rhsemshuffle/Makefile.am
new file mode 100644
index 0000000000..88448297cf
--- /dev/null
+++ b/testsuites/rhealstone/rhsemshuffle/Makefile.am
@@ -0,0 +1,23 @@
+MANAGERS = all
+
+rtems_tests_PROGRAMS = rhsemshuffle
+rhsemshuffle_SOURCES = semshuffle.c
+rhsemshuffle_SOURCES += ../../tmtests/include/timesys.h
+
+dist_rtems_tests_DATA = rhsemshuffle.adoc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(rhsemshuffle_OBJECTS) $(rhsemshuffle_LDADD)
+LINK_LIBS = $(rhsemshuffle_LDLIBS)
+
+rhsemshuffle$(EXEEXT): $(rhsemshuffle_OBJECTS) $(rhsemshuffle_DEPENDENCIES)
+ @rm -f rhsemshuffle$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am