summaryrefslogtreecommitdiffstats
path: root/testsuites/rhealstone/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/rhealstone/configure.ac')
-rw-r--r--testsuites/rhealstone/configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/testsuites/rhealstone/configure.ac b/testsuites/rhealstone/configure.ac
new file mode 100644
index 0000000000..e61dc2ebbb
--- /dev/null
+++ b/testsuites/rhealstone/configure.ac
@@ -0,0 +1,35 @@
+## Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([rtems-c-src-tests-rhealstone],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([taskswitch])
+AC_CONFIG_HEADER([config.h])
+RTEMS_TOP([../..],[..])
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE([no-define foreign 1.12.2])
+AM_MAINTAINER_MODE
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_RTEMS_TEST_NO_PAUSE
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+taskswitch/Makefile
+taskpreempt/Makefile
+ilatency/Makefile
+mlatency/Makefile
+semshuffle/Makefile
+deadlockbrk/Makefile
+])
+AC_OUTPUT