summaryrefslogtreecommitdiffstats
path: root/testsuites/rhealstone/configure.ac
diff options
context:
space:
mode:
authorDaniel Ramirez <javamonn@gmail.com>2014-01-04 13:58:44 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-01-05 09:58:39 -0600
commit19e9bf88004008308e0c9c7039a166c49477e0d1 (patch)
treedfdc847c722a17cc7e1b3e33afd83da809bf4e9d /testsuites/rhealstone/configure.ac
parentsp09: Remove partition specific parts (diff)
downloadrtems-19e9bf88004008308e0c9c7039a166c49477e0d1.tar.bz2
Added Rhealstone benchmark to testsuites
The Rhealstone benchmarks six operations that are critical components of a real-time system. It allows for an objective analysis to be performed, and allows for comparisons between systems. See rhealstone/README for more information.
Diffstat (limited to 'testsuites/rhealstone/configure.ac')
-rw-r--r--testsuites/rhealstone/configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/testsuites/rhealstone/configure.ac b/testsuites/rhealstone/configure.ac
new file mode 100644
index 0000000000..e61dc2ebbb
--- /dev/null
+++ b/testsuites/rhealstone/configure.ac
@@ -0,0 +1,35 @@
+## Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([rtems-c-src-tests-rhealstone],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([taskswitch])
+AC_CONFIG_HEADER([config.h])
+RTEMS_TOP([../..],[..])
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE([no-define foreign 1.12.2])
+AM_MAINTAINER_MODE
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_RTEMS_TEST_NO_PAUSE
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+taskswitch/Makefile
+taskpreempt/Makefile
+ilatency/Makefile
+mlatency/Makefile
+semshuffle/Makefile
+deadlockbrk/Makefile
+])
+AC_OUTPUT