summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtmtests/configure.ac')
-rw-r--r--testsuites/psxtmtests/configure.ac104
1 files changed, 52 insertions, 52 deletions
diff --git a/testsuites/psxtmtests/configure.ac b/testsuites/psxtmtests/configure.ac
index becaa2e03a..b2a711e3aa 100644
--- a/testsuites/psxtmtests/configure.ac
+++ b/testsuites/psxtmtests/configure.ac
@@ -77,56 +77,56 @@ AC_CHECK_SIZEOF([off_t])
OPERATION_COUNT=${OPERATION_COUNT-100}
AC_SUBST(OPERATION_COUNT)
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-psxtmbarrier01/Makefile
-psxtmbarrier02/Makefile
-psxtmbarrier03/Makefile
-psxtmbarrier04/Makefile
-psxtmclocknanosleep01/Makefile
-psxtmclocknanosleep02/Makefile
-psxtmclocknanosleep03/Makefile
-psxtmcond01/Makefile
-psxtmcond02/Makefile
-psxtmcond03/Makefile
-psxtmcond04/Makefile
-psxtmcond05/Makefile
-psxtmcond06/Makefile
-psxtmcond07/Makefile
-psxtmcond08/Makefile
-psxtmcond09/Makefile
-psxtmcond10/Makefile
-psxtmkey01/Makefile
-psxtmkey02/Makefile
-psxtmmq01/Makefile
-psxtmmutex01/Makefile
-psxtmmutex02/Makefile
-psxtmmutex03/Makefile
-psxtmmutex04/Makefile
-psxtmmutex05/Makefile
-psxtmmutex06/Makefile
-psxtmmutex07/Makefile
-psxtmnanosleep01/Makefile
-psxtmnanosleep02/Makefile
-psxtmrwlock01/Makefile
-psxtmrwlock02/Makefile
-psxtmrwlock03/Makefile
-psxtmrwlock04/Makefile
-psxtmrwlock05/Makefile
-psxtmrwlock06/Makefile
-psxtmrwlock07/Makefile
-psxtmsem01/Makefile
-psxtmsem02/Makefile
-psxtmsem03/Makefile
-psxtmsem04/Makefile
-psxtmsem05/Makefile
-psxtmsleep01/Makefile
-psxtmsleep02/Makefile
-psxtmthread01/Makefile
-psxtmthread02/Makefile
-psxtmthread03/Makefile
-psxtmthread04/Makefile
-psxtmthread05/Makefile
-psxtmthread06/Makefile
-])
+# BSP Test configuration
+RTEMS_TEST_CHECK([psxtmbarrier01])
+RTEMS_TEST_CHECK([psxtmbarrier02])
+RTEMS_TEST_CHECK([psxtmbarrier03])
+RTEMS_TEST_CHECK([psxtmbarrier04])
+RTEMS_TEST_CHECK([psxtmclocknanosleep01])
+RTEMS_TEST_CHECK([psxtmclocknanosleep02])
+RTEMS_TEST_CHECK([psxtmclocknanosleep03])
+RTEMS_TEST_CHECK([psxtmcond01])
+RTEMS_TEST_CHECK([psxtmcond02])
+RTEMS_TEST_CHECK([psxtmcond03])
+RTEMS_TEST_CHECK([psxtmcond04])
+RTEMS_TEST_CHECK([psxtmcond05])
+RTEMS_TEST_CHECK([psxtmcond06])
+RTEMS_TEST_CHECK([psxtmcond07])
+RTEMS_TEST_CHECK([psxtmcond08])
+RTEMS_TEST_CHECK([psxtmcond09])
+RTEMS_TEST_CHECK([psxtmcond10])
+RTEMS_TEST_CHECK([psxtmkey01])
+RTEMS_TEST_CHECK([psxtmkey02])
+RTEMS_TEST_CHECK([psxtmmq01])
+RTEMS_TEST_CHECK([psxtmmutex01])
+RTEMS_TEST_CHECK([psxtmmutex02])
+RTEMS_TEST_CHECK([psxtmmutex03])
+RTEMS_TEST_CHECK([psxtmmutex04])
+RTEMS_TEST_CHECK([psxtmmutex05])
+RTEMS_TEST_CHECK([psxtmmutex06])
+RTEMS_TEST_CHECK([psxtmmutex07])
+RTEMS_TEST_CHECK([psxtmnanosleep01])
+RTEMS_TEST_CHECK([psxtmnanosleep02])
+RTEMS_TEST_CHECK([psxtmrwlock01])
+RTEMS_TEST_CHECK([psxtmrwlock02])
+RTEMS_TEST_CHECK([psxtmrwlock03])
+RTEMS_TEST_CHECK([psxtmrwlock04])
+RTEMS_TEST_CHECK([psxtmrwlock05])
+RTEMS_TEST_CHECK([psxtmrwlock06])
+RTEMS_TEST_CHECK([psxtmrwlock07])
+RTEMS_TEST_CHECK([psxtmsem01])
+RTEMS_TEST_CHECK([psxtmsem02])
+RTEMS_TEST_CHECK([psxtmsem03])
+RTEMS_TEST_CHECK([psxtmsem04])
+RTEMS_TEST_CHECK([psxtmsem05])
+RTEMS_TEST_CHECK([psxtmsleep01])
+RTEMS_TEST_CHECK([psxtmsleep02])
+RTEMS_TEST_CHECK([psxtmthread01])
+RTEMS_TEST_CHECK([psxtmthread02])
+RTEMS_TEST_CHECK([psxtmthread03])
+RTEMS_TEST_CHECK([psxtmthread04])
+RTEMS_TEST_CHECK([psxtmthread05])
+RTEMS_TEST_CHECK([psxtmthread06])
+
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT