summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxsignal03/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psxsignal03/Makefile.am')
-rw-r--r--testsuites/psxtests/psxsignal03/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxsignal03/Makefile.am b/testsuites/psxtests/psxsignal03/Makefile.am
new file mode 100644
index 0000000000..9b2bc70a20
--- /dev/null
+++ b/testsuites/psxtests/psxsignal03/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxsignal03
+psxsignal03_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxsignal03.scn
+dist_rtems_tests_DATA += psxsignal03.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxsignal03_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxsignal03_OBJECTS) $(psxsignal03_LDADD)
+LINK_LIBS = $(psxsignal03_LDLIBS)
+
+psxsignal03$(EXEEXT): $(psxsignal03_OBJECTS) $(psxsignal03_DEPENDENCIES)
+ @rm -f psxsignal03$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am