summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxmsgq03/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psxmsgq03/Makefile.am')
-rw-r--r--testsuites/psxtests/psxmsgq03/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxmsgq03/Makefile.am b/testsuites/psxtests/psxmsgq03/Makefile.am
new file mode 100644
index 0000000000..15f6ae3273
--- /dev/null
+++ b/testsuites/psxtests/psxmsgq03/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxmsgq03
+psxmsgq03_SOURCES = init.c system.h ../include/pmacros.h \
+ ../../support/src/test_support.c
+
+dist_rtems_tests_DATA = psxmsgq03.scn
+dist_rtems_tests_DATA += psxmsgq03.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxmsgq03_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxmsgq03_OBJECTS) $(psxmsgq03_LDADD)
+LINK_LIBS = $(psxmsgq03_LDLIBS)
+
+psxmsgq03$(EXEEXT): $(psxmsgq03_OBJECTS) $(psxmsgq03_DEPENDENCIES)
+ @rm -f psxmsgq03$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am