summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxcancel01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psxcancel01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxcancel01/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxcancel01/Makefile.am b/testsuites/psxtests/psxcancel01/Makefile.am
new file mode 100644
index 0000000000..60225ab7b5
--- /dev/null
+++ b/testsuites/psxtests/psxcancel01/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxcancel01
+psxcancel01_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxcancel01.scn
+dist_rtems_tests_DATA += psxcancel01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxcancel01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxcancel01_OBJECTS) $(psxcancel01_LDADD)
+LINK_LIBS = $(psxcancel01_LDLIBS)
+
+psxcancel01$(EXEEXT): $(psxcancel01_OBJECTS) $(psxcancel01_DEPENDENCIES)
+ @rm -f psxcancel01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am