summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac22
1 files changed, 16 insertions, 6 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 16676a4610..3320b1c7a7 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -49,19 +49,29 @@ AC_CHECK_DECLS([pthread_attr_getguardsize],[],[],[[#include <pthread.h>]])
AC_CHECK_DECLS([pthread_attr_setguardsize],[],[],[[#include <pthread.h>]])
# Added to newlib pthreads for RTEMS SMP (np), may not be present
-AC_CHECK_DECLS([pthread_attr_setaffinity_np],[].[],,[[#include <pthread.h>]])
+AC_CHECK_DECLS([pthread_attr_setaffinity_np],[],[],[[
+ #define _GNU_SOURCE
+ #include <pthread.h>]])
# Added to newlib pthreads for RTEMS SMP (np), may not be present
-AC_CHECK_DECLS([pthread_attr_getaffinity_np],[].[],,[[#include <pthread.h>]])
+AC_CHECK_DECLS([pthread_attr_getaffinity_np],[],[],[[
+ #define _GNU_SOURCE
+ #include <pthread.h>]])
# Added to newlib pthreads for RTEMS SMP (np), may not be present
-AC_CHECK_DECLS([pthread_setaffinity_np],[].[],,[[#include <pthread.h>]])
+AC_CHECK_DECLS([pthread_setaffinity_np],[],[],[[
+ #define _GNU_SOURCE
+ #include <pthread.h>]])
# Added to newlib pthreads for RTEMS SMP (np), may not be present
-AC_CHECK_DECLS([pthread_getaffinity_np],[].[],,[[#include <pthread.h>]])
+AC_CHECK_DECLS([pthread_getaffinity_np],[],[],[[
+ #define _GNU_SOURCE
+ #include <pthread.h>]])
-# Added to newlib pthreads for RTEMS (np), may not be present
-AC_CHECK_DECLS([pthread_getattr_np],[].[],,[[#include <pthread.h>]])
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_DECLS([pthread_getattr_np],[],[],[[
+ #define _GNU_SOURCE
+ #include <pthread.h>]])
# Added to newlib pthreads for RTEMS SMP (np), may not be present
AC_CHECK_HEADERS([cpuset.h])