summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 48790591a5..756c07365d 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -41,10 +41,26 @@ AC_CHECK_DECLS([pthread_atfork],[],[],[[#include <pthread.h>]])
# Likely an anachronism in RTEMS.
AC_CHECK_DECLS([pthread_attr_getcputime],[],[],[[#include <pthread.h>]])
+# FIXME: RTEMS presumes pthread_attr_getcputime to be IEEE Std 1003.1
+# Likely an anachronism in RTEMS.
+AC_CHECK_DECLS([pthread_attr_getcputime],[],[],[[#include <pthread.h>]])
+
# FIXME: RTEMS presumes pthread_attr_setcputime to be IEEE Std 1003.1
# Likely an anachronism in RTEMS.
AC_CHECK_DECLS([pthread_attr_setcputime],[],[],[[#include <pthread.h>]])
+# Added to pthreads after initial revision. May not be in toolset
+AC_CHECK_DECLS([pthread_attr_getstack],[],[],[[#include <pthread.h>]])
+
+# Added to pthreads after initial revision. May not be in toolset
+AC_CHECK_DECLS([pthread_attr_setstack],[],[],[[#include <pthread.h>]])
+
+# Added to pthreads after initial revision. May not be in toolset
+AC_CHECK_DECLS([pthread_attr_getguardsize],[],[],[[#include <pthread.h>]])
+
+# Added to pthreads after initial revision. May not be in toolset
+AC_CHECK_DECLS([pthread_attr_setguardsize],[],[],[[#include <pthread.h>]])
+
# FIXME: adjtime is a non-standardized BSD/Linux extension
# RTEMS should not rely on adjtime
AC_CHECK_DECLS([adjtime],[],[],[[#include <sys/time.h>]])
@@ -129,6 +145,7 @@ psxsignal05/Makefile
psxspin01/Makefile
psxspin02/Makefile
psxstack01/Makefile
+psxstack02/Makefile
psxstat/Makefile
psxsysconf/Makefile
psxtime/Makefile