summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 82c56e3dbf..5131ac98a6 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -53,6 +53,10 @@ AC_CHECK_DECLS([adjtime],[],[],[[#include <sys/time.h>]])
# RTEMS provides a stub, despite newlib doesn't have sys/mman.h
AC_CHECK_DECLS([mprotect],[],[],[[#include <sys/mman.h>]])
+# FIXME: IEEE Std 1003.1-2008 mandates seteuid in unistd.h
+# RTEMS provides it, despite newlib doesn't declare it.
+AC_CHECK_DECLS([seteuid],[],[],[#include <unistd.h>])
+
# FIXME: We should get rid of this. It's a cludge.
AC_CHECK_SIZEOF([off_t])