summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp06/node1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/mptests/mp06/node1/Makefile.am')
-rw-r--r--testsuites/mptests/mp06/node1/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/testsuites/mptests/mp06/node1/Makefile.am b/testsuites/mptests/mp06/node1/Makefile.am
index 14a1da5896..bcd2c0a421 100644
--- a/testsuites/mptests/mp06/node1/Makefile.am
+++ b/testsuites/mptests/mp06/node1/Makefile.am
@@ -19,7 +19,28 @@ OBJS = $(lib_a_OBJECTS)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-include $(top_srcdir)/mptests.am
+
+project_bspdir=$(PROJECT_ROOT)
+
+$(project_bspdir)/tests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests
+ @: > $(project_bspdir)/tests/$(dirstamp)
+
+$(project_bspdir)/tests/$(TEST)-node$(NODE).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+ $(INSTALL_PROGRAM) $< $@
+
+$(project_bspdir)/tests/screens/mptests/node$(NODE)/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests/screens/mptests/node$(NODE)
+ @: > $(project_bspdir)/tests/screens/mptests/node$(NODE)/$(dirstamp)
+
+$(project_bspdir)/tests/screens/mptests/node$(NODE)/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/mptests/node$(NODE)/$(dirstamp)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = \
+$(project_bspdir)/tests/$(TEST)-node$(NODE).exe \
+$(project_bspdir)/tests/screens/mptests/node$(NODE)/$(TEST).scn
+
+$(PGM): ${ARCH}/$(dirstamp)
AM_CPPFLAGS += -DNODE_NUMBER=$(NODE) -I$(srcdir)/..