summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/mptests/configure.ac')
-rw-r--r--testsuites/mptests/configure.ac58
1 files changed, 16 insertions, 42 deletions
diff --git a/testsuites/mptests/configure.ac b/testsuites/mptests/configure.ac
index fca89117a1..f13759078d 100644
--- a/testsuites/mptests/configure.ac
+++ b/testsuites/mptests/configure.ac
@@ -32,46 +32,20 @@ MAX_LONG_TEST_DURATION=${MAX_LONG_TEST_DURATION-100}
AC_ARG_VAR([MAX_LONG_TEST_DURATION],
[The longest length of time a "long running" test should run])
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-mp01/Makefile
-mp01/node1/Makefile
-mp01/node2/Makefile
-mp03/Makefile
-mp03/node1/Makefile
-mp03/node2/Makefile
-mp04/Makefile
-mp04/node1/Makefile
-mp04/node2/Makefile
-mp05/Makefile
-mp05/node1/Makefile
-mp05/node2/Makefile
-mp06/Makefile
-mp06/node1/Makefile
-mp06/node2/Makefile
-mp07/Makefile
-mp07/node1/Makefile
-mp07/node2/Makefile
-mp08/Makefile
-mp08/node1/Makefile
-mp08/node2/Makefile
-mp09/Makefile
-mp09/node1/Makefile
-mp09/node2/Makefile
-mp10/Makefile
-mp10/node1/Makefile
-mp10/node2/Makefile
-mp11/Makefile
-mp11/node1/Makefile
-mp11/node2/Makefile
-mp12/Makefile
-mp12/node1/Makefile
-mp12/node2/Makefile
-mp13/Makefile
-mp13/node1/Makefile
-mp13/node2/Makefile
-mp14/Makefile
-mp14/node1/Makefile
-mp14/node2/Makefile
-])
+# BSP Test configuration
+RTEMS_TEST_CHECK([mp01])
+RTEMS_TEST_CHECK([mp03])
+RTEMS_TEST_CHECK([mp04])
+RTEMS_TEST_CHECK([mp05])
+RTEMS_TEST_CHECK([mp06])
+RTEMS_TEST_CHECK([mp07])
+RTEMS_TEST_CHECK([mp08])
+RTEMS_TEST_CHECK([mp09])
+RTEMS_TEST_CHECK([mp10])
+RTEMS_TEST_CHECK([mp11])
+RTEMS_TEST_CHECK([mp12])
+RTEMS_TEST_CHECK([mp13])
+RTEMS_TEST_CHECK([mp14])
+
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT