summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/top/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/top/Makefile.am')
-rw-r--r--testsuites/libtests/top/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/libtests/top/Makefile.am b/testsuites/libtests/top/Makefile.am
new file mode 100644
index 0000000000..c4aee3ae92
--- /dev/null
+++ b/testsuites/libtests/top/Makefile.am
@@ -0,0 +1,21 @@
+
+rtems_tests_PROGRAMS = top
+top_SOURCES = init.c task1.c task2.c task3.c system.h
+
+dist_rtems_tests_DATA = top.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(top_OBJECTS)
+LINK_LIBS = $(top_LDLIBS)
+
+top$(EXEEXT): $(top_OBJECTS) $(top_DEPENDENCIES)
+ @rm -f top$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am