summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/stackchk01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/stackchk01/Makefile.am')
-rw-r--r--testsuites/libtests/stackchk01/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/libtests/stackchk01/Makefile.am b/testsuites/libtests/stackchk01/Makefile.am
new file mode 100644
index 0000000000..dea58a1afe
--- /dev/null
+++ b/testsuites/libtests/stackchk01/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = io semaphore
+
+rtems_tests_PROGRAMS = stackchk01
+stackchk01_SOURCES = init.c
+
+dist_rtems_tests_DATA = stackchk01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+stackchk01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(stackchk01_OBJECTS) $(stackchk01_LDADD)
+LINK_LIBS = $(stackchk01_LDLIBS)
+
+stackchk01$(EXEEXT): $(stackchk01_OBJECTS) $(stackchk01_DEPENDENCIES)
+ @rm -f stackchk01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am