summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/stackchk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/stackchk/Makefile.am')
-rw-r--r--testsuites/libtests/stackchk/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/libtests/stackchk/Makefile.am b/testsuites/libtests/stackchk/Makefile.am
index c827a75abb..ee2b19af47 100644
--- a/testsuites/libtests/stackchk/Makefile.am
+++ b/testsuites/libtests/stackchk/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore
-rtems_tests_PROGRAMS = stackchk.exe
-stackchk_exe_SOURCES = blow.c init.c task1.c system.h
+rtems_tests_PROGRAMS = stackchk
+stackchk_SOURCES = blow.c init.c task1.c system.h
dist_rtems_tests_DATA = stackchk.scn
@@ -13,15 +13,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-stackchk_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+stackchk_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(stackchk_exe_OBJECTS) $(stackchk_exe_LDADD)
-LINK_LIBS = $(stackchk_exe_LDLIBS)
+LINK_OBJS = $(stackchk_OBJECTS) $(stackchk_LDADD)
+LINK_LIBS = $(stackchk_LDLIBS)
-stackchk.exe$(EXEEXT): $(stackchk_exe_OBJECTS) $(stackchk_exe_DEPENDENCIES)
- @rm -f stackchk.exe$(EXEEXT)
+stackchk$(EXEEXT): $(stackchk_OBJECTS) $(stackchk_DEPENDENCIES)
+ @rm -f stackchk$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am