summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/rtmonuse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/libtests/rtmonuse/Makefile.am')
-rw-r--r--testsuites/libtests/rtmonuse/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/testsuites/libtests/rtmonuse/Makefile.am b/testsuites/libtests/rtmonuse/Makefile.am
index 2f4e933ac6..a523629d94 100644
--- a/testsuites/libtests/rtmonuse/Makefile.am
+++ b/testsuites/libtests/rtmonuse/Makefile.am
@@ -19,7 +19,19 @@ PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-include $(top_srcdir)/libtests.am
+
+project_bspdir=$(PROJECT_ROOT)
+
+$(project_bspdir)/tests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests
+ @: > $(project_bspdir)/tests/$(dirstamp)
+
+$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+ $(INSTALL_PROGRAM) $< $@
+
+TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
+
+$(PGM): ${ARCH}/$(dirstamp)
#
# (OPTIONAL) Add local stuff here using +=